Scala in base al contenuto in Photoshop CC

0

Quante volte capita di avere una foto adatta a un particolare scopo e di non poterla usare perché è troppo larga, troppo stretta, lunga o corta. Con la funzione di Scala in base al contenuto potrete risolvere questo tipo di situazioni.

Scala in base al contenuto

Come comportarsi quando il formato di una foto non è adatto a uno scopo particolare, sebbene il contenuto sia perfetto? Se la foto è più grande ed è possibile tagliarla senza rovinarne il contenuto, allora siete fortunati, altrimenti come fare? Con la funzione Scala in base al contenuto, potete risolvere la situazione molto facilmente.
Questa funzione consente  di “tirare” le immagini da uno o più lati per raggiungere la dimensione corretta, preservando le aree importanti – come le persone o gli oggetti – ricomponendo poi l’immagine senza deformazioni.
Ovviamente il risultato non è sempre perfetto, per questo motivo è possibile proteggere manualmente aree precise dell’immagine, tramite una maschera che creeremo molto velocemente.
Per comprendere come funziona questo nuovo strumento, potete osservare la figura 1: sopra è presente l’immagine originale, mentre sotto, tirata da una freccia, trovate quella lavorata. Come potete vedere, la ragazza è rimasta perfettamente intatta, mentre lo sfondo è stato allungato: la percezione è di un’immagine corretta.

Figura 1: questa fotografia vi mostra l'immagine che è stata allargata senza deformare il soggetto principale

Figura 1: questa fotografia vi mostra l’immagine che è stata allargata senza deformare il soggetto principale

Con immagini semplici non sarà necessario fare particolari correzioni, ma in questo caso, seppure non si tratti di un’immagine particolarmente complessa, si dovranno fare dei piccoli interventi. Per prima cosa, proveremo a usare questa funzione con le sue impostazioni predefinite, per farvi vedere come funziona; successivamente vedremo come intervenire velocemente per correggere eventuali distorsioni non gradite.
Molto probabilmente la foto che aprirete sarà, per così dire, appiattita; per verificarlo, guardate nella palette Livelli: se il livello che contiene la foto riporta la scritta Sfondo, allora siete in questa situazione. Per usare questa funzionalità di Adobe Photoshop, è necessario farla diventare un livello vero e proprio: sempre nella palette Livelli, fate doppio clic sullo Sfondo; apparirà una finestra, in cui, se lo desiderate, potete assegnare un nome al livello. Noi, visto il soggetto, lo chiameremo Ragazza sulla spiaggia; infine fate clic sul pulsante OK.
Prima di effettuare qualsiasi ingrandimento, è necessario portare la dimensione del nostro foglio – che in Adobe Photoshop viene definito quadro – alla dimensione utile. Un’operazione da eseguire con una funzione specifica: nel menu Immagine selezionate Dimensione quadro. Volendo allargare l’immagine verso sinistra, nella finestra che viene visualizzata facciamo clic su uno qualsiasi dei quadrati sulla destra; questo indicherà che l’immagine sarà allargata nella direzione opposta.
La nostra fotografia è larga quasi 2.500 pixel e desideriamo farla diventare di 3.000 pixel, per cui, nel campo di testo Larghezza inseriamo il valore 3.000, assicurandoci che nel menu accanto sia utilizzata l’unità di misura adatta, nel nostro caso i pixel.

 

Figura 2: abbiamo allargato il quadro che contiene la fotografia per stabilire la dimensione che vogliamo raggiungere

Figura 2: abbiamo allargato il quadro che contiene la fotografia per stabilire la dimensione che vogliamo raggiungere

Ora che abbiamo stabilito quanto deve diventare grande la nostra immagine, facciamo la prima prova di ridimensionamento, per vedere cosa accade. Dal menu Modifica selezionate l’opzione Scala in base al contenuto; nella barra delle opzioni, accanto all’opzione Proteggi, fate clic sul pulsante Protegge l’incarnato, rappresentato con il disegno di un omino: questo serve per migliorare la protezione delle tonalità di colore della pelle umana.
Come potrete notare, sull’immagine sono apparse le classiche maniglie simili a quelle della funzione Scala.
Per ridimensionare la foto verso sinistra, prendete la maniglia centrale sul lato sinistro; provate a trascinarla fino a raggiungere il bordo del quadro e, per confermare l’operazione, premete il tasto Invio sulla tastiera.
Cosa è successo? Come potete vedere nella figura 3, alcune parti, evidenziate con cerchi arancioni, si sono deformate, il seno ha delle sbavature, le mani si sono decisamente deformate e per finire il braccio si è assottigliato. Nel prossimo passaggio vedremo come fare per evitare questo fastidioso effetto.

Figura 3: usando le impostazioni predefinite, abbiamo ottenuto una deformazione in alcune parti dell’immagine che potete vedere evidenziate dai cerchi bianchi

Figura 3: usando le impostazioni predefinite, abbiamo ottenuto una deformazione in alcune parti dell’immagine che potete vedere evidenziate dai cerchi bianchi

Se non avessimo attivato il pulsante Protegge l’incarnato nella barra delle opzioni, il risultato sarebbe stato anche peggiore di quello visibile nella figura 3; infatti, non preservando le tinte della figura umana, avremmo ottenuto una ragazza in sovrappeso.

Protezione delle aree

Come abbiamo visto, nel nostro caso si è verificata una deformazione non gradita. Per questo motivo, Adobe ha pensato di prevedere la possibilità di proteggere alcune zone manualmente, preservandole durante l’ingrandimento.
Per prima cosa annullate l’ultima operazione andando nel menu Modifica e selezionando Annulla oppure, mediante la palette Storia, tornate al passo precedente semplicemente facendoci clic sopra o se preferite premete la combinazione di tasti Cmd+Z se usate OS X o Ctrl+Z se usate Windows.
Per proteggere un’area, dovremo per prima cosa creare una selezione. Per i nostri scopi non è necessaria una selezione precisa; è sufficiente che la ragazza sia compresa nella selezione, anche senza uno scontorno perfetto. Lo Strumento selezione rapida è più che adatto. Per usarlo spostatevi sull’area da selezionare e, tenendo premuto il tasto del mouse, trascinatelo all’interno dei contorni dell’area, fino a coprire tutte le parti interessate. Lo Strumento selezione rapida è molto efficace: è sufficiente trascinarlo su un’area per selezionarla e proseguire sulla successiva, anche se di colore diverso. Per aggiungere pezzi di selezione, se rilasciate il tasto del mouse, non è necessario premere il tasto Maiusc sulla tastiera: infatti la selezione viene mantenuta.
Se la selezione non vi soddisfa pienamente, potete aggiungerne dei pezzi tramite lo Strumento lazo o la funzione Modifica in modalità maschera veloce, disponibile nella barra degli strumenti. Se utilizzate lo Strumento lazo, tenete premuto il tasto Maiusc, altrimenti deselezionerete quanto selezionato in precedenza. Nella figura 4 potete vedere la nostra selezione, che non è precisa, ma sufficiente per il nostro scopo.

Figura 4: per eseguire un ridimensionamento più preciso, è possibile proteggere alcune aree eseguendo una selezione

Figura 4: per eseguire un ridimensionamento più preciso, è possibile proteggere alcune aree eseguendo una selezione

Dopo aver ottenuto una selezione soddisfacente, aprite il menu Selezione e fate clic sull’opzione Salva selezione; nella finestra che appare assegnate un nome alla selezione, per esempio Ragazza, e salvatela facendo clic sul pulsante OK. A questo punto deselezionate la foto premendo la combinazione di tasti Cmd+D, se usate OS X, o Ctrl+D, se usate Windows; infatti, una volta salvata, la selezione non servirà più.
Ora riproveremo a effettuare nuovamente l’operazione di ingrandimento. Come fatto in precedenza, andate nel menu Modifica e selezionate l’opzione Scala in base al contenuto; nella barra delle opzioni selezionate dal menu Proteggi la selezione salvata precedentemente, nel nostro caso Ragazza, e disattivate il pulsante con raffigurato l’omino (che in questo caso, oltre a essere inutile, produrrebbe deformazioni non desiderate). Quindi afferriamo con il mouse la maniglia centrale di sinistra e trasciniamola fino al margine del quadro; infine premiamo Invio sulla tastiera per confermare l’opzione.
Nella figura 5 potete osservare il risultato finale: davvero sorprendente, non trovate? Con un semplice mascheramento delle aree che prima provocavano deformazioni, abbiamo ottenuto un risultato in grado di ingannare chiunque, con un lavoro di circa cinque minuti.

Figura 5: con poco lavoro siamo riusciti ad allargare una fotografia che sarà in grado di ingannare chiunque. Nessuna distorsione è visibile

Figura 5: con poco lavoro siamo riusciti ad allargare una fotografia che sarà in grado di ingannare chiunque. Nessuna distorsione è visibile

Soggetti più complessi

La funzione Scala in base al contenuto è davvero molto efficace, ma come si comporta se le diamo in pasto contenuti più difficili? Proviamo a osservare la figura 6: in questo caso abbiamo una ragazza che passeggia sulla spiaggia e un po’ di persone in secondo piano; un gruppo sulla destra della foto e due persone che sembrano guardare in lontananza sulla sinistra.
In questo caso la nostra immagine è larga 2.000 pixel, ma ha un orientamento decisamente verticale. Per mostrarvi l’efficacia di questa funzione, faremo diventare questa foto orizzontale, portandola da 2.000 pixel a ben 3.000 pixel.

Figura 6: con la funzione Scala in base al contenuto, trasformeremo questa foto da verticale a orizzontale lasciando il soggetto principale al centro

Figura 6: con la funzione Scala in base al contenuto, trasformeremo questa foto da verticale a orizzontale lasciando il soggetto principale al centro

Come abbiamo fatto prima, portiamo la dimensione del quadro a 3.000 pixel, ma questa volta, volendo mantenere il soggetto principale al centro, la allargheremo su entrambi i lati. Anche in questo caso, assicuratevi che nella palette Livelli l’immagine non sia lo sfondo; altrimenti non potremo usare la funzione.
Dal menu Immagine, selezionate Dimensione quadro; nella finestra che appare fate clic sul quadrato centrale: questo farà in modo che l’immagine si allarghi su entrambi i lati. Nel riquadro di testo Larghezza inserite il valore 3.000 e premete il pulsante OK per confermare. Il quadro si allargherà lasciando al centro la fotografia originale.
Trattandosi di una foto complessa, dovremo proteggere le aree da preservare. Vi consigliamo di effettuare una prima selezione delle persone con lo Strumento selezione rapida e poi di andare in fondo alla palette degli strumenti e attivare l’opzione Modifica in modalità maschera veloce. Alternando l’uso del bianco e del nero come colore di primo piano, rispettivamente per mascherare o nascondere aree, utilizzate il pennello per rifinire meglio la selezione. Potete usare lo Strumento pennello con diverse dimensioni e sfumature; per esempio, nella zona dei capelli usate un pennello grande e sfumato, in modo da tenere nella selezione anche i capelli più piccoli.
Non è necessaria una selezione precisa: l’importante è che al suo interno ci sia tutto quello che c’è da proteggere; nello stesso tempo, però, cercate di non includere nella selezione parti troppo estese dello sfondo.
Per farvi un’idea di quello che intendiamo, osservate la selezione che abbiamo eseguito nella figura 7.

Figura 7: per utilizzare la funzione Scala in base ai contenuti non è necessario eseguire selezioni complesse

Figura 7: per utilizzare la funzione Scala in base ai contenuti non è necessario eseguire selezioni complesse

Se avete utilizzato la funzione Modifica in modalità maschera veloce, tornate in fondo alla barra degli strumenti e fate clic su Modifica in modalità standard. A questo punto, andate nel menu Selezione e selezionate Salva selezione, assegnandole il nome Aree protette.
Non rimane che provare ad allargare la nostra fotografia: dal menu Modifica selezionate l’opzione Scala in base al contenuto; nella barra delle opzioni selezionate dal menu Proteggi la selezione salvata precedentemente, nel nostro caso Aree protette, e controllare che il pulsante con raffigurato l’omino sia disattivo; sulla foto appariranno le consuete maniglie: prendete quelle al centro e trascinate la maniglia di destra verso destra e la maniglia di sinistra verso sinistra. Durante il procedimento noterete come le persone si distanziano, ma mantengono le proporzioni.
Come si può osservare nella figura 8, il risultato è davvero sorprendente. Anche con fotografie più complesse, questa funzione di Adobe Photoshop permette addirittura di trasformare una foto verticale in una orizzontale, il tutto senza deformare le persone. Ora potete allargare le vostre foto per portarle alla dimensione che preferite.

Figura 8: con la funzione Scala in base al contenuto, abbiamo trasformato una foto verticale in orizzontale, senza deformare i soggetti.

Figura 8: con la funzione Scala in base al contenuto, abbiamo trasformato una foto verticale in orizzontale, senza deformare i soggetti.


Autore: Luca Bertolli – CHP Multimedia

90%
90
Voto
  • Giudizio degli utenti (98 Voti)
    9.3
Condividi.

I commenti sono chiusi.